← Back to Vulnerability Reports CVE Intelligence

CVE-2026-45205

Apache Commons Configuration•MEDIUM · CVSS 5.3•No exploitation reported

What is CVE-2026-45205?

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

CVSS5.3 NVD 3.1
SeverityMEDIUM
ExploitationNo exploitation reported
EPSS<1% · P41
Triage statusNo Known Exploit
ActionSchedule for next cycle
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CWECWE-674
NVD published2026-05-14
NVD last modified2026-10-26

Timeline

  • 2026-05-14Published to the U.S. National Vulnerability Database (NVD)
  • 2026-10-26NVD record last updated

Affected product

Apache Commons Configuration

Remediation Steps

  1. Review ABB ICSA-26-120-06 advisory identifying affected Symphony Plus Engineering versions
  2. Evaluate PostScript processing vulnerabilities in your deployed configurations
  3. Apply vendor-recommended security updates to all affected installations
  4. Disable PostScript processing features if not essential to business operations
  5. Implement input validation and filtering for PostScript document handling

Referenced in our briefings & reports

Related vulnerabilities

Apache: 41 known exploited vulnerabilities (CISA KEV) →

Browse all tracked CVEs in the defend.network CVE database →

🤖 This CVE page is generated by defend.network from NVD, CISA KEV, EPSS, and our verified daily briefings. Severity and exploitation data come from official sources; always verify remediation steps against the official vendor advisory before acting in production.